Adventure Motorcycle Magazine Subscribe Now

Results 1 to 3 of 3
  1. #1 650NK Electrical Issue 
    C-Moto Noob
    Join Date
    Oct 2016
    Location
    australia
    Posts
    6
    Hi, own a 2013 650nk in Australia that I ride every day rain or shine, and has never let me down, well until now. The bike has developed a strange and annoying electrical issue. When the bike is running and in gear the neutral light will glow dimly, when you turn the bike off in gear there is no glow. I have disconnected the neutral switch completely and the issue was still there. The bike also will now start in gear with the side stand down (proven using rear paddock stand), and also after about 2mins of running it throws o2 codes. I have been through the schematic in the service manual to the best of my ability and I cannot find anything other than there appears to be a 0.5v diffence from ecu to neutral switch compared to dash neutral light to neutral switch when i seperate the circuit which could be enough to cause the dim glow. So I spoke to my local dealer and he lent me 2 used ecuís that has know idle issues and I tired them, unfortunately all the issues I have were replicated across both the borrowed ecuís, yes I know I should of tried a new one but at $800+ AUD for a new one it was something I wasnít willing to try and fail at. So after the ecu trial I sourced a used wiring harness from a later 2015 bike and installed that, guess what, no fix. Iíve proved itís not the bikes voltage reg as itís only dimly glowing when the bike is running by starting my bike with the volt reg disconnected on battery volts only and neutral light not on in gear then connecting another bike to my batter via jumper lead, start my bike then started other bike that was then charging my battery and what do you know the neutral light was on again in gear. It seems to happen when bike voltage is raised to 14v charging volts. I was so over it that I parked my bike up outside under cover for 2 weeks rather than park it in the shed as I normally do as a bit of punishment. Well I had to move the bike the other day and you wouldnít believe it, but there was no neutral glow in gear, Iím like what is going on here.... decided to ride the bike to work this week and all was good for 5 days, until Friday afternoon and it went back to its old ways. Iím at my wits ends with this bike. Has anyone has a similar issue, or had this electrical gremlin and was able to fix it? Any help would be much appreciated. Itís a great looking and riding bike so Iím trying my hardest to fix this and get back on the road and start to trust it again like I used to as my daily rider.... thanks and HHHHEEEELLLLLPPPPPPPPPPP
    Reply With Quote  
     

  2. #2  
    C-Moto Guru
    Join Date
    Jul 2014
    Location
    Poland
    Posts
    327
    Try to change the battery, and look of the wirring from battery to frame, maybe something is not properly fastened
    Reply With Quote  
     

  3. #3 Re: 650NK Electrical Issue 
    C-Moto Noob
    Join Date
    Oct 2016
    Location
    australia
    Posts
    6
    Thanks for your suggestion “beniamin82” but unfortunately I have already tried a new / different battery and all the earths have been checked because I have replaced the whole bikes wiring loom so they were all cleaned and tested. I’ve had a little play with the bike, and it seems the issue of the bike starting in gear with stand down can be made happen as soon as the ecu see’s a neutral indication by that I mean if I power on the bike in neutral then shift to a gear with the stand down, I am able to fire the bike over. But if I leave the bike in a gear, power on and try to start, it won’t turn over until I select neutral or earth the neutral wire at the switch to cause the N light to illuminate then shift into a gear I can start the bike in gear with stand down. It’s like the ecu holds the ok to start state. I’m at a loss to understand other than it’s pointing back to the ecu, which I have replicated the issues between 2 other ecu’s that we’re not know to have the problem.... if the bike wasn’t so dam good looking I would just walk away from it and part it out..........
    Reply With Quote  
     

Similar Threads

  1. electrical weatherproofin' !!
    By Paul.D86 in forum Maintenance
    Replies: 5
    Last Post: 08-24-2015, 04:06 AM
  2. zongshen electrical
    By AnimalTk in forum Dirt n' Dual-Sport
    Replies: 1
    Last Post: 12-15-2013, 07:20 AM
  3. An Electrical Challenge
    By aje in forum Maintenance
    Replies: 5
    Last Post: 12-01-2013, 06:28 PM
  4. Big electrical issues ?
    By John2v in forum Maintenance
    Replies: 18
    Last Post: 07-31-2012, 12:11 AM
  5. electrical problems
    By nycsumo in forum Dirt n' Dual-Sport
    Replies: 5
    Last Post: 11-15-2010, 03:57 PM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •