Adventure Motorcycle Magazine Subscribe Now

Results 1 to 2 of 2
  1. #1 650 tk died at idle 
    C-Moto Not-so-Noob
    Join Date
    Jul 2019
    Location
    Australia
    Posts
    16
    I just bought an 015 650tk ...since I have had the bike the red f1 indicator has been flashing 15 short flashes ..I canít find any reference to 15 short flashes in the error codes in the manual or anywhere online.
    The bikes seems to be riding normally ..on last ride I was idling at a traffic light and there was a pop kind of a sound, sounded like a vacuum or air related sound. The bike immediately died as the sound occurred. It started back up normally right away only difference was the red f1 indicator was no longer doing the 15 flashes..this lasted for about 2 minutes of riding before it came back.
    Has anyone had this problem or have any idea what this could be?
    I tried to reset the error codes first by doing the procedure I read about here then by disconnecting the battery for 20 mins neither worked.

    Thanks for any help!
    Reply With Quote  
     

  2. #2 Re: 650 tk died at idle 
    C-Moto Not-so-Noob
    Join Date
    Jul 2019
    Location
    Australia
    Posts
    16
    Ok so a new error code showed up ..I looked it up on the code table and it’s says the error is 2 cylinder ignition coil .... would that make sense with the symptom I posted about in the above message a sort of puff or pop sound then the bike either dies or the rpms go way down then up then stabilise...seems to mainly happen at idle or low speeds ...I thought maybe it was my riding as I grew up on bikes but it’s been many years since I have ridden until recently... I have found it choppy to ride at slow speeds and low rpms ...like around 3k rpm the bike vibrates a lot ... which is an annoying range for it not to be smooth ....if you shift up you are too slow for the next gear ...if you push past to 4K and beyond where it smooths out your in the power band and hauling a$$ ...so yeah been feathering a lot etc to avoid all that vibration and get a smooth ride at low speeds which is what the majority of in town riding is especially on the crazy roads here in Sydney ....anyone know is that how the tk rides..maybe me riding poorly or could that also be a symptom of a failing ignition coil?
    Reply With Quote  
     

Similar Threads

  1. Adjusting the Idle Screw
    By MatthewHalsey in forum Maintenance
    Replies: 2
    Last Post: 07-06-2015, 10:06 PM
  2. Replies: 8
    Last Post: 11-16-2013, 12:39 PM
  3. lost power, and then the bike died..
    By slabo in forum Maintenance
    Replies: 8
    Last Post: 01-08-2011, 04:21 PM
  4. pulse 125 gy died no electric!
    By Dan in forum Maintenance
    Replies: 5
    Last Post: 02-22-2010, 04:56 PM
  5. throttle sometimes locked and bad idle....
    By txm123 in forum Maintenance
    Replies: 1
    Last Post: 11-21-2009, 04:36 AM
Tags for this Thread

View Tag Cloud

Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •