Adventure Motorcycle Magazine Subscribe Now

Results 1 to 9 of 9
  1. #1 Cfmoto 650 tk just stopped running 
    C-Moto Not-so-Noob
    Join Date
    Jul 2019
    Location
    Australia
    Posts
    16
    Hi all

    So I have suspected the ecu has been going bad for awhile. Today while riding all of a sudden the bike just shut off while going along at slow speeds..
    When I tried to restart it turning the ignition switc off then on to restart ...the fuel pump did not prime as usual and nothing when I pressed the starter button .. the gauges and lights al l still had full power ..but nothing not a click from the starter as if it is getting zero power.

    I ave checked all the fuses including the main fuse and all is good. I have checked and tested the battery which is good.

    I am thinking it is the ecu but wanted to ask a few questions before I get a new one ..
    The side stand switch has not worked since I bought the bike ..one of the reasons I think the ecu is bad as itís a common fault when the ecu starts failing.. the side switch basically shuts off the bike right ..but you would still get the f1 light working and fuel pump if this for some reason was bad and stopping the bike ?

    The other thing Iím thinking of testing is the roll over sensor ...but again if the roll over sensor was preventing the bike from starting ..the fuel pump would still prime and the f1 system still work right..

    The fuses are good ...the battery is good but it seems the ignition system has no power while the rest of the bike still has power... I will test the ignition switch tomorrow , maybe that has gone bad ....if that was the fault then yeah neither the f1 fuel pump or starter would work ...but if the switch is good ...given the battery and fuses are good ....and what I wrote about the two sensors tip over and side stand ..the only thing I can think of is the ecu not initialising ...
    Am I right here if the ecu goes bad ..you would not get anything or the f1 diagnostic when you turn the ignition switch on .... can anyone think of any other reason or anything else to check?

    Ecus are expensive so want to check everything before buying a new one..

    Thanks to anyone that has any ideas..

    Cheers
    Rob
    Reply With Quote  
     

  2. #2 Re: Cfmoto 650 tk just stopped running 
    C-Moto Not-so-Noob
    Join Date
    Jul 2019
    Location
    Australia
    Posts
    16
    Does anyone know if the TK and the NK are using the same ECUS? Will an ecu for The nk work in the Tk if they are from the same year?
    Reply With Quote  
     

  3. #3 Re: Cfmoto 650 tk just stopped running 
    foreign China moto dude bikerdoc's Avatar
    Join Date
    Oct 2009
    Location
    Zhejiang PRC, OZ, NZ
    Posts
    2,297
    Shiet, sorry to read of the news. It sounds to me like the ECU.
    Sounds like you've checked the obvious sources of consternation, did you check the battery terminals? Although sounds like all good in that area based on your report...
    Is yours a Ducati model ECU? I've had two Ducati branded ECUs go bad. One on my 1st gen 650TR and one on my 1st gen Jetmax maxi scoot. I can't recall now exactly what the symptoms were to be able to guide you as it was a few years back now. But basically a kind of comatosed bike but still alive. I just trying to recall what the instrument panels did or didn't do, but am struggling with what I actually recall observing.
    Had to bite the bullet and buy two new ECUs, and as you rightly point out - not cheap and this was inside the mainland. I can only imagine the prices here in OZ or outside China. It sounds like a faulty ECU. I'm not sure if sending the ECU off to some ECU programmer like ECUnleashed is possible for a fix or not, but might worth a search on whether or not it's possible to have the ECU looked at. Many companies out there working on ECUs and with the costs of replacement might be a viable alternative.
    In relation to swapping out ECU between the various CF650 models, the bike models (650) use essentially the same engine, so just check that the ECUs are like for like e.g. Ducati vs Bosch the latter of which CFMoto moved to on the later models (circa 2016+). Otherwise, you should be good to go. The only thing is if you do swap you'll likely have to get the ECU calibrated using the ECU programmer which likely means a visit to a CFMoto stealership with the aforementioned calibration plug-in device. My two bikes ran okay when I swapped out my ECUs, rode fine, but did have slightly less than ideal idles but not a major issue, however I did notice a discernible difference after having the ECUs calibrated mainly with the idling.
    Hope you get it sorted...
    Let us know how you get on.
    Reply With Quote  
     

  4. #4 Re: Cfmoto 650 tk just stopped running 
    C-Moto Not-so-Noob
    Join Date
    Jul 2019
    Location
    Australia
    Posts
    16
    Bikerdoc so many thanks for the reply mate! I just remembered you sent me an email about two months ago I completely forgot to reply to ..so sorry mate will get to that ASAP!

    Yes it’s a Ducati ecu ... one weird thing ...even though my bike is a 2015 it seems to be the older style before the upgrades ..no USB port ..Ducati ecu etc etc must of been made in 2013 or 14 and then sold in 2015 something like that dunno! Is it not the case that the new tks nks all got many upgrades in 2015?
    But yeah did the final test today.. tested the on off switch and it’s good and has power so it can only be the ecu at this point ..if the fuses are good there is power to all the switches and they all work etc the battery is good...the side stand kill and roll over sensor are not the cause ..what else can it be!
    So I ordered one off Alibaba.com ...a bit pricey for an old ecu that is bloody known to always fail like you mentioned ! Ended up being around 450 once shipping and the rest was paid ...turns out the ecu is the same model on the nks tks and trs ...I was surprised as I had been told the tr an tk were tuned differently as they are touring bikes ...the one stealership that got back to me wanted almost 900 for the ecu ..insane! Now that’s a markup !
    I did look into possibly having the ecu repaired as you mentioned at some point ..turns out these Ducati ecus are sealed so no one can get into them..they won’t even attempt it ..once I get the new one I may find a way to cut my old one open without damaging the internals so in the future we all have the option to repair ...if succesful will post the method on here ..I have some ideas..
    Well my bike always ran weird anyways ..I tried everything to fix it ..new coils..new plugs....flushed all fuel lines and tank ...new injectors ..new fuel pump ..tested and cleaned 02 sensors ..tried it all .....my. Bike threw multiple error codes that don’t exist ..has really really bad fuel mileage ..backfires through the air box ...intermittent stalls after backfire through the air box and recently when I did a long haul sydney to Canberra started dying twice for around 5- 10 kms each time while doing around 110 ....it also had a very snatchy throttle ..took some real control and finesse with the clutch and throttle to ride it smooth especially in 1st and 2nd gear and during slow turns ....also the side stand stop did not function ...so yeah have been thinking of an ecu replacement for awhile anyways...hopefully afterwards she will ride like a different bike ...I read a thread about an nk on netrider where he had many of my same symptoms which all were fixed instantly by the new ecu ...one weird thing though ..several people have mentioned in different threads a dim neutral light as a symptom ..from what I can tell the neutral light does not run through the ecu ..when I took my ecu out today ..I turned the key to on and the gauges and neutral light ..all of that still functioned with the ecu removed ..which would tell me they are independant systems and not controlled by the ecu ...strange then that people had a dimming neutral light as an ecu going bad symptom?
    As always mate so many thanks for your reply and advice! Very much appreciated how much you always help everyone out here! Seems like just about any post on here where someone is looking for advice on a 600 cfmoto bike you are always there to help..awesome of you mate!

    Cheers
    Rob
    Reply With Quote  
     

  5. #5 Re: Cfmoto 650 tk just stopped running 
    foreign China moto dude bikerdoc's Avatar
    Join Date
    Oct 2009
    Location
    Zhejiang PRC, OZ, NZ
    Posts
    2,297
    Hey Rob, not a worry. I'm willing to help out where I can. Sounds like your 650TK is maybe a 2014 manufactured model, and so sat as older stock on the shop floor before being sold perhaps. It's quite a common occurrence where a new model sold in a particular year is old stock which was from the previous year manufacturing run. It seems to happen with all the makes/models with some level of frequency. I've seen it in a number of countries too where a stealership has sold an older model (previous year or sometimes a few years older model) new, under the guise as a current model. Sometimes this is just a mistake where the sales dept didn't know any better or sometimes it's a crafty calculated pull on an under-educated unsuspecting buyer.
    Sounds as though you have an older model, perhaps 2nd generation CF650TK with the flawed Ducati ECU, unfortunately. The later generations as outlined previously came supplied with Bosch ECUs and the two aren't interchangeable nor are various components that work through the ECU.

    Bonus that you found yourself a replacement ECU for half the cost thru a local stealership, although is it a new ECU or used or reconditioned? Being from the motherland, anything is possible, no matter what the seller may claim. So long as it does as described on the tin.

    Once you get the replacement it's simple plug and play. You may need to have it calibrated though, but the bike should start and 'run' okay. Without the re-calibration of the ECU to the EFI etc the bike may idle a little rough. I had both my bikes re-calibrated and it did make a difference.

    Since you'll have the old replaced ECU, I'd be inclined to send it to the guy working on ECUs you've seen on Gumtree or contact ECUnleashed to see if it can be jailbroken into. There's a thread on the YamahaSuperTenere forum about the 1st generation Yamaha Super Tenere (Super10 aka S10) XT1200Z which also has/had a sealed ECU (don't they all), which ECUnleashed were able to infiltrate and lay down new maps etc. This cured the off-idle stumble and low-mid range stumble in the lower gears for the first gen Super10. Point being that the CFMoto ECUs likely can be jailbroken into.

    Dunno where the info came from about the 650NK vs 650TR models being all that different unless comparing different model years and generations (1st gen vs 2nd gen vs 3rd gen etc). All the 650 models share the same engine and running gear especially the early models and therefore the same ECU.

    From reading all the various symptoms your TK has had, it sounds as though the ECU was out of calibration early on?

    So long as the bike runs and does so without any significant issues I don't pay much attention to the F1 light. Hell the sidestand light on my Jetmax has been lit since a day or ten after I bought it. Still runs and rides fine.

    Let's see how it goes when you fit the replacement ECU.
    Learn the rules like a pro, so you can break them like an artist
    - Pablo Picasso
    Reply With Quote  
     

  6. #6 Re: Cfmoto 650 tk just stopped running 
    C-Moto Not-so-Noob
    Join Date
    Jul 2019
    Location
    Australia
    Posts
    16
    Bikerdoc : again mate many thanks for the reply and help!
    To answer your questions , this is supposed to be a brand new ecu from the factory, I got it from alibaba in China..so yeah was hard to make the order and communicate with them and the worst part about it ..is shipping time ...I ordered on Friday, they had to order it from the factory ..so week end nothing ...then 3 days ish from Monday before they have it in hand then 5-7 days for it to get here ...my bike is my only form of transport so stuck without anything for at least 10 days sucks!
    I took your advice and contacted ecuunleashed ...offered to send them my old ecu to play with and see if they can find a way to get 8nto it so they can repair or remap them ....I will post here what happens..will be an amazing resource for any Aussie Cfmoto owners if we have an alternative to buying a new one when these units fail! Who knows what they may be able to accomplish with some remapping as well ..that would be cool! I have not heard back from them as of yet.
    Yes this bike has been very buggy for me so far ..and I have tried all kinds of things to sort her out ...but really it’s probably been just that ecu on it’s way out the whole way! Here’s hoping I throw the new one in and all is solved ....I wonder how much those Cfmoto tools that hook up to the ecu cost .lif it’s not stupidly priced maybe worthwhile for me to get one so I don’t have to run to a dealer every time...

    I was reading online that I may have to readjust the tps to the new ecu ....although I found a procedure for the er6 that you don’t need to hook up to a scanner to accomplish the tps adjustment ...getting to a Cfmoto dealer here that knows what they are doing is a real pain ...I have heard nothing but bad things about the closest main one in town ..apparently everyone says go to the one way up in Gosford hours away ...hoping 8mdont have to run up there just to have the new ecu calibrated right haha
    I love this bike, once I figured out how to ride her properly it is a real pleasure to ride around ...the biggest complaint is how hard it is to get work done on it and find parts ..but otherwise these tk bikes are a great bike once you figure out how to ride them properly!

    Hey one quick question for you l..I got a gear indicator from eBay ..it’s a little device that has two sensors that you put down above and below your shift lever..a magnet is then put on the shift lever and a small display shows what gear you are in ....the instructions that came with it are really bad....I kind of get all of it except for the labeling of one wire...it just says neutral ...I’m guessing this means it connects to the neutral switch so the device knows when the bike is in neutral ....any ideas of the best way to connect this wire to the neutral switch without causing any problems? I’m worried I connect it and some sort of voltage change occurs which causes problems with the neutral switch ..dunno..

    Again many thanks for all of your help mate! I will update what happens and if we figure something out regarding modifying and fixing these ecus!
    Reply With Quote  
     

  7. #7 Re: Cfmoto 650 tk just stopped running 
    C-Moto Not-so-Noob
    Join Date
    Jul 2019
    Location
    Australia
    Posts
    16
    Bikerdoc: you were spot on mate! New ecu arrived today, it was a five minute job and the bike started right up...all the problems were instantly gone..no more flashing of the F1 indicator ..won’t start in gear anymore ..no backfires or erratic throttle! Honestly mate it feels like a brand new bike ..like it has at least double the power at least! The slogging around the 3-4k rpm mark ...gone ...the backfires and erratic idle gone ..I feel like I have a new bike it rides so nicely it’s amazing the difference is staggering how much better it is! I’m really thrilled! I was considering selling it and buying a more mainstream bike once it was fixed..you know like a cbr 500 or something as it would just be easier to source parts and fix .lbut yeah enjoying the ride so much now I ave chang3d my mind!
    For anyone out there with a Cfmoto that has a Ducati ecu ..which is the first few years they make the NK and Tk ...if you develope any of the symptoms I spoke about above or a combination of them ..before you start changing parts or going to a mechanic etc etc save yourself a lot of pain hassle and frustration ..yank out the ecu ..it’s a two minute job it’s just under the seat ..and have it tested ..I have read this story over and over where people spend a ton of money and time changing all kinds of parts and diagnosing when in the end all they needed was the new ecu...
    Reply With Quote  
     

  8. #8 Re: Cfmoto 650 tk just stopped running 
    foreign China moto dude bikerdoc's Avatar
    Join Date
    Oct 2009
    Location
    Zhejiang PRC, OZ, NZ
    Posts
    2,297
    Quote Originally Posted by Rszarka View Post
    Bikerdoc : again mate many thanks for the reply and help!
    To answer your questions , this is supposed to be a brand new ecu from the factory, I got it from alibaba in China..so yeah was hard to make the order and communicate with them and the worst part about it ..is shipping time ...I ordered on Friday, they had to order it from the factory ..so week end nothing ...then 3 days ish from Monday before they have it in hand then 5-7 days for it to get here ...my bike is my only form of transport so stuck without anything for at least 10 days sucks!
    I took your advice and contacted ecuunleashed ...offered to send them my old ecu to play with and see if they can find a way to get 8nto it so they can repair or remap them ....I will post here what happens..will be an amazing resource for any Aussie Cfmoto owners if we have an alternative to buying a new one when these units fail! Who knows what they may be able to accomplish with some remapping as well ..that would be cool! I have not heard back from them as of yet.
    Yes this bike has been very buggy for me so far ..and I have tried all kinds of things to sort her out ...but really it’s probably been just that ecu on it’s way out the whole way! Here’s hoping I throw the new one in and all is solved ....I wonder how much those Cfmoto tools that hook up to the ecu cost .lif it’s not stupidly priced maybe worthwhile for me to get one so I don’t have to run to a dealer every time...

    I was reading online that I may have to readjust the tps to the new ecu ....although I found a procedure for the er6 that you don’t need to hook up to a scanner to accomplish the tps adjustment ...getting to a Cfmoto dealer here that knows what they are doing is a real pain ...I have heard nothing but bad things about the closest main one in town ..apparently everyone says go to the one way up in Gosford hours away ...hoping 8mdont have to run up there just to have the new ecu calibrated right haha
    I love this bike, once I figured out how to ride her properly it is a real pleasure to ride around ...the biggest complaint is how hard it is to get work done on it and find parts ..but otherwise these tk bikes are a great bike once you figure out how to ride them properly!

    Hey one quick question for you l..I got a gear indicator from eBay ..it’s a little device that has two sensors that you put down above and below your shift lever..a magnet is then put on the shift lever and a small display shows what gear you are in ....the instructions that came with it are really bad....I kind of get all of it except for the labeling of one wire...it just says neutral ...I’m guessing this means it connects to the neutral switch so the device knows when the bike is in neutral ....any ideas of the best way to connect this wire to the neutral switch without causing any problems? I’m worried I connect it and some sort of voltage change occurs which causes problems with the neutral switch ..dunno..

    Again many thanks for all of your help mate! I will update what happens and if we figure something out regarding modifying and fixing these ecus!
    Hi Rob, sorry for the delay in replying. Sounds like you finally got all the gremlins sorted. Yipee! It's kinda interesting that all the little issues you have experienced with the bike all point back to a failing ECU. Good to know that the replacement has sorted things for your ride. How have you got on with the ol' ECU and sending it away to be jailbroken?
    About the Gear Indicator - you've likely resolved the install by now, but, connecting into the neutral light/switch wire using a positap or similar wire splice shouldn't cause any grief.
    Learn the rules like a pro, so you can break them like an artist
    - Pablo Picasso
    Reply With Quote  
     

  9. #9 Re: Cfmoto 650 tk just stopped running 
    foreign China moto dude bikerdoc's Avatar
    Join Date
    Oct 2009
    Location
    Zhejiang PRC, OZ, NZ
    Posts
    2,297
    Quote Originally Posted by Rszarka View Post
    Bikerdoc: you were spot on mate! New ecu arrived today, it was a five minute job and the bike started right up...all the problems were instantly gone..no more flashing of the F1 indicator ..won’t start in gear anymore ..no backfires or erratic throttle! Honestly mate it feels like a brand new bike ..like it has at least double the power at least! The slogging around the 3-4k rpm mark ...gone ...the backfires and erratic idle gone ..I feel like I have a new bike it rides so nicely it’s amazing the difference is staggering how much better it is! I’m really thrilled! I was considering selling it and buying a more mainstream bike once it was fixed..you know like a cbr 500 or something as it would just be easier to source parts and fix .lbut yeah enjoying the ride so much now I ave chang3d my mind!
    For anyone out there with a Cfmoto that has a Ducati ecu ..which is the first few years they make the NK and Tk ...if you develope any of the symptoms I spoke about above or a combination of them ..before you start changing parts or going to a mechanic etc etc save yourself a lot of pain hassle and frustration ..yank out the ecu ..it’s a two minute job it’s just under the seat ..and have it tested ..I have read this story over and over where people spend a ton of money and time changing all kinds of parts and diagnosing when in the end all they needed was the new ecu...
    Yeah agree totally... changing out the ECU would be the first choice, albeit a costly choice mind, which causes one a moment of pause and to try less expensive options first.
    Learn the rules like a pro, so you can break them like an artist
    - Pablo Picasso
    Reply With Quote  
     

Similar Threads

  1. CF650TR - Horn stopped working
    By linuxyeti in forum Maintenance
    Replies: 4
    Last Post: 06-07-2016, 09:42 AM
  2. Running-in
    By Foisix in forum Maintenance
    Replies: 24
    Last Post: 04-16-2015, 08:18 AM
  3. RMR 125 Running problem
    By shaun69 in forum Maintenance
    Replies: 12
    Last Post: 06-23-2011, 05:17 PM
  4. Cold Running
    By choldy in forum Maintenance
    Replies: 9
    Last Post: 12-27-2010, 02:03 PM
  5. Fuel tap - when stopped
    By Azbo in forum Maintenance
    Replies: 7
    Last Post: 12-22-2010, 02:56 PM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •